Requirements

Python 3.5 or above is required. (see next section for Python 2.x support)

PyFtdi relies on PyUSB, which itself depends on one of the following native libraries:

  • libusb, currently tested with 1.0.21

PyFtdi does not depend on any other native library, and only uses standard Python modules along with PyUSB and pyserial.

PyFtdi has been tested with PyUSB 1.0.0.

  • PyUSB 1.0.0b1 or below is no longer supported.

Note

Note about previous releases

If you have no choice but using previous releases of software, such as

  • Python (2.6+, 3.3+),

  • other PyUSB backends such as the deprecated libusb-0.1, or openusb,

  • PyUSB 1.0.0b1 or below,

  • pyserial 2.6+ (previous versions of pyserial will NOT work)

please checkout the latest PyFtdi 0.1x series (0.13.3) which provides support for these deprecated environmement, but is no longer actively maintained.

Development

PyFtdi is developed on macOS platforms (64-bit kernel), and is validated on a regular basis on Linux hosts.

As it contains no native code, it should work on any PyUSB and libusb supported platforms. However, M$ Windows is a seamless source of issues and is not officially supported, although users have reported successful installation with Windows 7 for example. Your mileage may vary.